论坛: 系统集成 标题: 路由器调试?????????????????????????????? 复制本贴地址    
作者: 郁闷十分 [ddrddr]    论坛用户   登录
现有MAIPU2692路由器一台,

在调试过程中出现如下问题:

用于网站的路由器上有三个公网IP,

其中IP1、IP2的配置完全是一模一样,都是在路由器上直接做NAT和路由

但是做了NAT以后,跟IP1做静态转换的内网机器可以被转换出去,也可转换进来,

但是与IP2做静态转换的内网机子死活就是进不去,出不来,

不明白,由于本人才入行,所以在路由器上的配置只是做了访问列表,静太路由,NAT,

其它的东西都没有动过,我觉得可能是哪个地方协议或什么属性不对,

请各位指点,

谢谢,

在线等待中---------------------------------------------------

地主 发表时间: 04-02-11 07:40

回复: Achieve [achieve]   版主   登录
把配置贴上来

B1层 发表时间: 04-02-11 10:09

回复: 郁闷十分 [ddrddr]   论坛用户   登录
这是现有配置,

但是当我再用一个IP将现有的IP  57 替换掉时网络就不通了,

或是加一个IP然后把其它的私网IP和加上来的公网IP做NAT时加上来那一块就不通了,

如加上一个56与内网IP的NAT,那么相应的内网IP也上不了网了,

router>en
password:
router#show run
Building Configuration...done

Current configuration: 1343 bytes

version 4.2.6(integrity)

hostname router
enable password NVOWXVRSUSNSSSUS encrypt
no service password-encrypt
no service enhanced-secure

snmp-server view default 1.3.6.1 include

ip access-list standard 1
permit 192.168.0.0 0.0.0.255
deny any
exit

ip access-list extended 1001
deny udp any eq 69 any
deny udp any eq 4444 any
deny tcp any eq 4444 any
deny tcp any any range 135 139
deny udp any any range 135 139
deny tcp any any eq 445
deny udp any any eq 445
permit ip any any
exit





interface loopback0
exit

interface fastethernet0
ip address 61.243.94.57 255.255.255.128
ip access-group 1001 in
ip nat outside
exit

interface fastethernet1
ip address 192.168.0.1 255.255.255.0
ip nat inside
exit

ip nat pool maipu 61.243.94.56 61.243.94.56 netmask 255.255.255.128
ip nat inside source static 192.168.0.5 61.243.94.57
ip nat inside source static 192.168.0.10 61.243.94.57
ip nat inside source static 192.168.0.7 61.243.94.57
ip nat inside source static 192.168.0.4 61.243.94.57
ip nat inside source static 192.168.0.2 61.243.94.57
ip nat inside source static 192.168.0.252 61.243.94.55
ip nat inside source static 192.168.0.3 61.243.94.57
ip nat inside source list 1 pool maipu overload

ip route 0.0.0.0 0.0.0.0 61.243.94.1
ip route 61.243.94.55 255.255.255.255 61.243.94.1
ip route 61.243.94.56 255.255.255.255 61.243.94.1


B2层 发表时间: 04-02-11 10:52

回复: 大话网络 [guiguaigu]   论坛用户   登录
哪个地址不能出去?

B3层 发表时间: 04-02-11 11:12

回复: 郁闷十分 [ddrddr]   论坛用户   登录
谢谢各位关心,

经过一天一夜的大战,主要问题己经解决了,


现在内网的机子全部可以通过地址池内的IP访问外网了,


不过也邪门的很,


我给老板打电话说事情没有办好,东西调的有问题

结果刚放下电话,这边就顺了,   

跟我以前调的一样,


想不通,好像老天爷想故意捉弄我一样,

郁闷--------------------------



多谢各位关心


B4层 发表时间: 04-02-11 12:19

论坛: 系统集成

20CN网络安全小组版权所有
Copyright © 2000-2010 20CN Security Group. All Rights Reserved.
论坛程序编写:NetDemon

粤ICP备05087286号