论坛: 系统集成 标题: 请高手帮忙!!HELP~~~~~~~~~ 复制本贴地址    
作者: Wasteman [serverxp]    论坛用户   登录
小弟家里是ADSL接入,拿CISCO1721做拨号!!做了如下配置以后,电脑已经可以上网了!但是出现一个问题:有一些站点访问不了。比如微软主页(www.microsoft.com/china)还有上海热线2(www.online2.sh.cn)等。但是其它的站点的访问一切正常,包括QQ也正常登陆。请高手们帮忙,请问这是什么问题?另外如何解决??以下是我的配置:

Cisco1721#sh ru
Building configuration...

Current configuration : 1183 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco1721
!
enable secret 5 $1$VH.f$LZIFAPGRNMdYZR6SPafsE0
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
!
vpdn enable
!
vpdn-group 1
request-dialin
  protocol pppoe
!
!
!
!
interface Ethernet0
no ip address
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0
ip address 192.168.0.254 255.255.255.0
ip nat inside
speed auto
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username ad******** password 7 *********
!
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 192.168.0.1 21 interface Dialer1 21
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
ip pim bidir-enable
!
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 5 0
password **********
login
!
no scheduler allocate
end/


[此贴被 Wasteman(serverxp) 在 11月25日05时29分 编辑过]


[此贴被 Wasteman(serverxp) 在 11月25日05时45分 编辑过]

地主 发表时间: 05-11-25 05:28

回复: 带脚镣跳舞 [tuzi]   版主   登录
大文件能否正常下载?


B1层 发表时间: 05-11-25 09:40

回复: 带脚镣跳舞 [tuzi]   版主   登录
背景知识]
MTU: Maxitum Transmission Unit 最大传输单元

MSS: Maxitum Segment Size 最大分段大小(偶是直译,翻译的不好,不要打
俺PP)

PPPoE: PPP Over Ethernet(在以太网上承载PPP协议)

[分析过程]
先说说这MTU最大传输单元,这个最大传输单元实际上和链路层协议有着密切
的关系,让我们先仔细回忆一下EthernetII帧的结构
DMAC+SMAC+Type+Data+CRC
由于以太网传输电气方面的限制,每个以太网帧都有最小的大小64bytes
最大不能超过1518bytes,对于小于或者大于这个限制的以太网帧我们都可以
视之为错误的数据帧,一般的以太网转发设备会丢弃这些数据帧。
(注:小于64Bytes的数据帧一般是由于以太网冲突产生的“碎片”或者线路干扰
或者坏的以太网接口产生的,对于大于1518Bytes的数据帧我们一般把它叫做
Giant帧,这种一般是由于线路干扰或者坏的以太网口产生)

由于以太网EthernetII最大的数据帧是1518Bytes这样,刨去以太网帧的帧头
(DMAC目的MAC地址48bit=6Bytes+SMAC源MAC地址48bit=6Bytes+Type域
2bytes)14Bytes和帧尾CRC校验部分4Bytes(这个部门有时候大家也把它叫做
FCS),那么剩下承载上层协议的地方也就是Data域最大就只能有1500Bytes
这个值我们就把它称之为MTU。这个就是网络层协议非常关心的地方,因为网络
层协议比如IP协议会根据这个值来决定是否把上层传下来的数据进行分片。就好
比一个盒子没法装下一大块面包,我们需要把面包切成片,装在多个盒子里面一
样的道理。

当两台远程PC互联的时候,它们的数据需要穿过很多的路由器和各种各样的网络
媒介才能到达对端,网络中不同媒介的MTU各不相同,就好比一长段的水管,由
不同粗细的水管组成(MTU不同 :))通过这段水管最大水量就要由中间最细的水管决定。

对于网络层的上层协议而言(我们以TCP/IP协议族为例)它们对水管粗细不在意
它们认为这个是网络层的事情。网络层IP协议会检查每个从上层协议下来的数据
包的大小,并根据本机MTU的大小决定是否作“分片”处理。分片最大的坏处就是
降低了传输性能,本来一次可以搞定的事情,分成多次搞定,所以在网络层更高
一层(就是传输层)的实现中往往会对此加以注意!有些高层因为某些原因就会
要求我这个面包不能切片,我要完整地面包,所以会在IP数据包包头里面加上一
个标签:DF(Donot Fragment)。这样当这个IP数据包在一大段网络(水管里
面)传输的时候,如果遇到MTU小于IP数据包的情况,转发设备就会根据要求
丢弃这个数据包。然后返回一个错误信息给发送者。这样往往会造成某些通讯上
的问题,不过幸运的是大部分网络链路都是MTU1500或者大于1500。

对于UDP协议而言,这个协议本身是无连接的协议,对数据包的到达顺序以及是
否正确到达不甚关心,所以一般UDP应用对分片没有特殊要求。

对于TCP协议而言就不一样了,这个协议是面向连接的协议,对于TCP协议而言
它非常在意数据包的到达顺序以及是否传输中有错误发生。所以有些TCP应用对
分片有要求---不能分片(DF)。

花开两朵,各表一枝,说完MTU的故事我们该讲讲今天的第二个猪脚---PPPoE
所谓PPPoE就是在以太网上面跑PPP协议,有人奇怪了,PPP协议和Ethernet不
都是链路层协议吗?怎么一个链路层跑到另外一个链路层上面去了,难道升级
成网络层协议了不成。其实这是个误区:就是某层协议只能承载更上一层协议。
为什么会产生这种奇怪的需求呢?这是因为随着宽带接入(这种宽带接入一般
为Cable Modem或者xDSL或者以太网的接入)由于以太网缺乏认证计费机制
而传统运营商是通过PPP协议来对拨号等接入服务进行认证计费的,所以就
出了这么一个怪胎:PPPoE。(有关PPPoE的详细介绍参见V大以及本站其他成
员的一些介绍文章,我就不啰里啰唆的了)

PPPoE带来了好处,也带来了一些坏处,比如:二次封装耗费资源,降低了传输
效能等等,这些坏处俺也不多说了,最大的坏处就是PPPoE导致MTU变小了
以太网的MTU是1500,再减去PPP的包头包尾的开销(8Bytes),就变成
1492。

如果两台主机之间的某段网络使用了PPPoE那么就会导致某些不能分片的应用
无法通讯。

这个时候就需要我们调整一下主机的MTU,通过降低主机的MTU,这样我们
就能够顺利地进行通讯了。

当然对于TCP应用而言还有另外的解决方案。
马上请出今天第三位猪脚:MSS。
MSS最大传输大小的缩写,是TCP协议里面的一个概念。
MSS就是TCP数据包每次能够传输的最大数据分段。为了达到最佳的传输效能
TCP协议在建立连接的时候通常要协商双方的MSS值,这个值TCP协议在实现的
时候往往用MTU值代替(需要减去IP数据包包头的大小20Bytes和TCP数据段的
包头20Bytes)所以往往MSS为1460。通讯双方会根据双方提供的MSS值得最小
值确定为这次连接的最大MSS值。

介绍完这三位猪脚s
我们回过头来看前言里面的那个问题,我们试想一下,如果我们在中间路由器上
把每次TCP连接的最大MSS进行调整这样使得通过PPPoE链路的最大MSS值加上
数据包头包尾不会超过PPPoE的MTU大小1492这样就不会造成无法通讯的问题

所以上面的问题可以通过ip tcp adjust-mss 1452来解决。

当然问题也可以通过修改PC机的MTU来解决。

[后记]
Cisco在IOS 12.2(4)T及以后的版本支持修改MSS大小的特性

Cisco的TCP Adjust MSS Feature:

The TCP MSS Adjustment feature enables the configuration of the
maximum segment size (MSS) for transient packets that traverse a router,
specifically TCP segments in the SYN bit set, when Point to Point Protocol
over Ethernet (PPPoE) is being used in the network. PPPoE truncates the
Ethernet maximum transmission unit (MTU) 1492, and if the effective MTU
on the hosts (PCs) is not changed, the router in between the host and the
server can terminate the TCP sessions. The ip tcp adjust-mss command
specifies the MSS value on the intermediate router of the SYN packets to
avoid truncation.


B2层 发表时间: 05-11-25 10:21

回复: Wasteman [serverxp]   论坛用户   登录
恩恩。谢谢!

[此贴被 Wasteman(serverxp) 在 11月26日01时29分 编辑过]

B3层 发表时间: 05-11-25 20:12

回复: Rootong [tommy_he]   版主   登录
我只能说,日,有钱,拨号都用1721,好贵啊。。。。。

B4层 发表时间: 05-11-26 01:37

论坛: 系统集成

20CN网络安全小组版权所有
Copyright © 2000-2010 20CN Security Group. All Rights Reserved.
论坛程序编写:NetDemon

粤ICP备05087286号